EVPN Lab – OSPF Configuration

Here we are! The official start of the long awaited EVPN Lab series! We are going to start out the EVPN Lab with OSPF Configuration. If you are having some doubts on your OSPF skills, you can head over to OSPF Basics for a quick refresher!

What are we going to configure in this lab:

- Underlay IGP is OSPF, the following must be configured:
    - Process - UNDERLAY
    - All addressed interfaces on the device should added to the routing protocol in area 0
    - All links must be configured as point to point links
    - All links must have authentication enabled with the following parameters
      - Use Message Digest
          - Password: P@55w0rd

To get the working files for this lab, you can head over to my Github to download the UNL and startup-config files. Let’s get into it!

What are we working with?

The physical diagram was shared in our previous post {{ internal link }}. When we are done configuring OSPF, the logical topology should look like this

OSPF topology

Let’s address the elephant in the room. I know everything should not be in area 0, but I wanted to keep it simple and it’s not a production network. I mean even if it was, you would be surprised what I have seen…

Configuring OSPF

There is going to be a lot of repetition, so we are only going to configure two devices which are Leaf01 and BorderLeaf-01. Let’s break down the steps:

  • Enable the OSPF Feature
    • This will generate errors since we do not have a license installed. For the purposes of this blog, we can ignore them
  • Start the OSPF Process
  • Configure a router ID under the OSPF process
    • Where X is, use the IP address from loopback10 from this device
  • Configure the ethernet interfaces to participate in OSPF with the following parameters:
    • Message Digest Authentication with the password being P@55w0rd
    • Configure the links as OSPF network type point-to-point
    • Put the interfaces into area 0
  • Configure the loopback interfaces to participate in OSPF with the following parameters:
    • Configure the links as OSPF network type point-to-point
    • Put the interfaces into area 0
feature ospf
router ospf UNERLAY
 router-id 10.1.0.x
 
interface Ethernet1/1
  ip ospf authentication message-digest
  ip ospf authentication-key 3 81edc54affecb0aa
  ip ospf network point-to-point
  ip router ospf UNDERLAY area 0.0.0.0
  no shutdown

interface Ethernet1/2
  ip ospf authentication message-digest
  ip ospf authentication-key 3 81edc54affecb0aa
  ip ospf network point-to-point
  ip router ospf UNDERLAY area 0.0.0.0
  no shutdown

interface loopback10
  ip ospf network point-to-point
  ip router ospf UNDERLAY area 0.0.0.0

interface loopback20
  ip ospf network point-to-point
  ip router ospf UNDERLAY area 0.0.0.0

Verification

Perfect, now we can verify to make sure that OSPF is up and learning routes. A few things to note:

  1. My output could look different than yours, I will make sure to point out what you are looking for in the output
  2. I am only going to issue the commands on one device to not turn this blog into a 500 page thesis.

These are the verification commands we are going to run:

  • show ip ospf neighbor
    • There should be two neighbors, and their state should both be full
Leaf-01# show ip ospf neighbor
 OSPF Process ID UNDERLAY VRF default
 Total number of neighbors: 2
 Neighbor ID     Pri State            Up Time  Address         Interface
 10.1.0.1          1 FULL/ -          00:02:34 10.0.0.1        Eth1/1
 10.1.0.2          1 FULL/ -          00:02:42 10.0.0.29       Eth1/2

  • show ip route ospf | count
    • There should be two neighbors, and their state should both be full
Leaf-01# show ip route ospf | count
75

  • show ip ospf database
    • You should only see 9 router link states (Area 0.0.0.0)
Leaf-01# show ip ospf database
        OSPF Router with ID (10.1.0.3) (Process ID UNDERLAY VRF default)

                Router Link States (Area 0.0.0.0)

Link ID         ADV Router      Age        Seq#       Checksum Link Count
10.1.0.1        10.1.0.1        226        0x80000004 0x3d1a   16
10.1.0.2        10.1.0.2        234        0x80000004 0xf8d0   16
10.1.0.3        10.1.0.3        230        0x80000004 0xc3da   6
10.1.0.4        10.1.0.4        232        0x80000004 0x1674   6
10.1.0.5        10.1.0.5        232        0x80000004 0x680e   6
10.1.0.6        10.1.0.6        232        0x80000004 0xbaa7   6
10.1.0.7        10.1.0.7        232        0x80000004 0x0d41   6
10.1.0.8        10.1.0.8        232        0x80000004 0x5fda   6
10.1.0.9        10.1.0.9        232        0x80000004 0xb174   6

  • ping some loopback interfaces
Leaf-01# ping 10.1.0.9 source-interface loopback10
PING 10.1.0.9 (10.1.0.9): 56 data bytes
64 bytes from 10.1.0.9: icmp_seq=0 ttl=253 time=7.477 ms
64 bytes from 10.1.0.9: icmp_seq=1 ttl=253 time=6.335 ms
64 bytes from 10.1.0.9: icmp_seq=2 ttl=253 time=4.782 ms
64 bytes from 10.1.0.9: icmp_seq=3 ttl=253 time=4.337 ms
64 bytes from 10.1.0.9: icmp_seq=4 ttl=253 time=4.442 ms

--- 10.1.0.9 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 4.337/5.474/7.477 ms
Leaf-01# ping 10.10.10.9 source-interface loopback10
PING 10.10.10.9 (10.10.10.9): 56 data bytes
64 bytes from 10.10.10.9: icmp_seq=0 ttl=253 time=5.247 ms
64 bytes from 10.10.10.9: icmp_seq=1 ttl=253 time=5.11 ms
64 bytes from 10.10.10.9: icmp_seq=2 ttl=253 time=7.122 ms
64 bytes from 10.10.10.9: icmp_seq=3 ttl=253 time=4.801 ms
64 bytes from 10.10.10.9: icmp_seq=4 ttl=253 time=4.697 ms

--- 10.10.10.9 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 4.697/5.395/7.122 ms

OK we have OSPF all configured and verified working! Did you have any problems, or did you configure OSPF a different way? Let me know what you did in the comments below or over on my socials! Next on the list we are going to configure multicast! See you on the next one!